RESOLVED: SaaS disruption at EU2 hosting location

Incident Report for TOPdesk SaaS Status page

Resolved

The issue has been fixed by Microsoft and most environments are already back online.
All remaining environments will become available again automatically within the next few minutes
Posted Apr 01, 2025 - 12:19 CEST

Update

The issue has been identified and is currently being fixed
Posted Apr 01, 2025 - 11:55 CEST

Update

Microsoft confirmed the issues and are actively investigating
Posted Apr 01, 2025 - 11:43 CEST

Update

We identified an issue with the storage, resulting in servers losing access to their harddisk.
This issue is not affecting all of EU2 but only a subset of servers.

We reached out to our hosting provider Microsoft to investigate
Posted Apr 01, 2025 - 11:20 CEST

Investigating

We are currently experiencing problems on our EU2 hosting location
As a result your TOPdesk environment may not be available.


We are aware of the problem and are working on a solution.

Our apologies for the inconvenience. At the time of writing this we are not able to give you an estimate on when your environment will be available. We aim to update this status page every 30 minutes until the issue has been resolved.

E-mail updates will be sent when the issue has been resolved. You can subscribe on the status page (https://status.topdesk.com) for additional updates.

To inform TOPdesk you are affected by this issue, please visit My TOPdesk.
Posted Apr 01, 2025 - 10:56 CEST
This incident affected: EU2 SaaS hosting location.