RESOLVED: We are currently experiencing problems with automated actions on our NL3 hosting
Incident Report for TOPdesk SaaS Status page
Postmortem

On June 11th, from approximately 11:30 to 13:30, our NL3 hosting location experienced a major incident. After a redeployment of the action service, all messages related to automated actions remained in the queue without being delivered to the action service, which resulted in automated actions not being executed. In response, we restarted the action service on NL3. After a brief period where the action service caught up on executing all actions triggered after 11:30, the behavior of the automated action system went back to normal. While the exact root cause remains under investigation, this incident has provided invaluable insights. These insights are being used as a basis for ongoing improvement in our understanding and management of our messaging system. We are confident that with these insights, we will eventually be able to pinpoint the root cause of this incident with a high degree of certainty. We acknowledge these incidents as opportunities for systematic improvement and remain committed to leveraging this experience to ensure increased reliability and stability in our service.

Posted Jul 05, 2024 - 10:26 CEST

Resolved
The issue has been resolved. A number of our clients have confirmed that their actions are now being triggered as expected.

Customers are encouraged to contact support if they continue to experience issues.

Thank you for your patience and our apologies for the inconvenience this issue has caused.
Posted Jun 11, 2024 - 13:30 CEST
Monitoring
We have successfully rebooted the action service software, and all actions are now being initiated as expected.

Please be aware that any actions that have been triggered, either manually or automatically, but are still in a queue, will now be executed.

We are actively monitoring the situation to ensure system stability.
Posted Jun 11, 2024 - 13:18 CEST
Investigating
We are currently experiencing problems with automated actions on our NL3 hosting location.

As a result your automated actions may not trigger.

We are aware of the problem and are working on a solution.

Our apologies for the inconvenience. At the time of writing this we are not able to give you an estimate on when your environment will be available. We aim to update this status page every 30 minutes until the issue has been resolved.

E-mail updates will be sent when the issue has been resolved. You can subscribe on the status page (https://status.topdesk.com) for additional updates.

To inform TOPdesk you are affected by this issue, please visit https://my.topdesk.com/tas/public/ssp/ . Please refer to incident TDR24 06 3491.
Posted Jun 11, 2024 - 13:00 CEST
This incident affected: NL3 SaaS hosting location.