RESOLVED: Performance issues on multiple hosting locations

Incident Report for TOPdesk SaaS Status page

Resolved

Cloudflare has closed their incident after confirming that network performance has been restored. We have not observed further impact on TOPdesk environments and have also received positive feedback from customers confirming service stability.
Posted Dec 19, 2025 - 15:28 CET

Monitoring

Cloudflare has implemented a fix for the network performance issues and is monitoring the results.


We are also monitoring the situation across our own TOPdesk environments and will provide further updates as they become available.
Posted Dec 19, 2025 - 13:42 CET

Investigating

We are currently experiencing disruptions across multiple hosting locations. As a result, your TOPdesk environment may experience degraded performance or temporary unavailability.

We are investigating the issue, which may be related to a disruption at an external service provider. For reference, Cloudflare’s service status can be found here:
https://www.cloudflarestatus.com/

Please contact TOPdesk Support after submitting an incident, so we can store additional logfiles to investigate this.

Our apologies for the inconvenience. At the time of writing this we are not able to give you an estimate on when your environment will be available. We aim to update this status page every 30 minutes until the issue has been resolved.

E-mail updates will be sent when the issue has been resolved. You can subscribe on the status page (https://status.topdesk.com) for additional updates.

To inform TOPdesk you are affected by this issue, please visit My TOPdesk.
Posted Dec 19, 2025 - 13:26 CET
This incident affected: AU1 SaaS hosting location, BR1 SaaS hosting location, CA1 SaaS hosting location, EU1 SaaS hosting location, EU5 SaaS hosting location, and US1 SaaS hosting location.