RESOLVED: SaaS degraded performance
Incident Report for TOPdesk SaaS Status page
Resolved
We have been aware of this issue and have been actively investigating the root cause. Despite our efforts, we have not been able to definitively determine where the problem originates. However, following feedback from several customers who are no longer experiencing long response times or slow performance in their environments, we have decided to close the major incident.

If you are still experiencing slow performance in your TOPdesk environment, please reopen your incident by replying to this email, or directly via https://my.topdesk.com/. We will handle individual incidents separately.

Thank you for your understanding.
Posted Mar 05, 2024 - 13:25 CET
Update
We are investigating whether the performance issues that some customers have been experiencing still persist, and we are continuing to explore possible causes.

If you are still experiencing issues with performance, kindly update your ticket with details of your experience.
Posted Mar 05, 2024 - 10:09 CET
Update
Investigations into the degraded performance issue, do not show any issues with several of the biggest Internet Service Providers within Denmark.

We will continue our investigation and will update the status page as soon as we have more information about this issue.

Our apologies for the inconvenience.
Posted Mar 04, 2024 - 16:11 CET
Update
We are still investigating the increased loading times, Cloudflare error messages and degraded performance, but are still not sure what the cause of the disruption is.

We have concluded that only Danish customers are affected by this, and are therefore focused on these.

We are investigating an issues with multiple internet service providers within Denmark.
Posted Mar 04, 2024 - 14:36 CET
Investigating
We are currently experiencing issues on multiple hosting locations, this might result in increased loading times, Cloudflare error messages and degraded performance. 

We are aware of the problem and are investigating the cause.

Our apologies for the inconvenience. At the time of writing this we are not able to give you an estimate on when the issue will be resolved. We aim to update this status page every 30 minutes until the issue has been resolved.

E-mail updates will be sent when the issue has been resolved. You can subscribe on the status page (https://status.topdesk.com) for additional updates.

To inform TOPdesk you are affected by this issue, please visit https://my.topdesk.com/tas/public/ssp/ . Please refer to incident TDR24 03 849.
Posted Mar 04, 2024 - 13:50 CET
This incident affected: AU1 SaaS hosting location, BR1 SaaS Hosting location, CA1 SaaS hosting location, EU1 SaaS hosting location, NL3 SaaS hosting location, UK1 SaaS hosting location, and US1 SaaS hosting location.