RESOLVED: Major 'Problems with images in knowledge items'

Incident Report for TOPdesk SaaS Status page

Resolved

Our development department was able to create a solution for the problem. We have implemented this solution in all environments and have already received positive feedback. However, in order for the solution to work, all images in the affected knowledge articles must be re-uploaded.

We apologise for any inconvenience caused.
Posted Jan 16, 2026 - 16:25 CET

Update

Our developers are still researching the issue. We will provide you with further information as soon as we have it.
Posted Jan 16, 2026 - 14:59 CET

Update

Research by our developers is still ongoing. A recent change in our code seems to be the likely cause. We will provide you with further information as soon as we have it.
Posted Jan 16, 2026 - 13:55 CET

Investigating

We are currently experiencing multiple issues related to new rich text functionalities in the Knowledge Management module, specifically when images are included in knowledge items or news items.

We are aware of the problem and are working on a solution.

Our apologies for the inconvenience. The next update will be provided as events warrant until the issue has been resolved.

E-mail updates will be sent right away when the issue has been resolved. You can subscribe on the status page (https://status.topdesk.com) for additional updates.

To inform TOPdesk you are affected by this issue, please visit https://my.topdesk.com/tas/public/ssp/ . Please refer to incident TDR26 01 4577.
Posted Jan 16, 2026 - 12:41 CET
This incident affected: Functionality malfunction.