The issue has been identified and resolved. You can now log in to MyTOPdesk again. We are keeping a close eye on the situation. We apologise for the inconvenience.
Posted Mar 16, 2026 - 19:09 CET
Monitoring
The issue has been identified and resolved. You can now log in to MyTOPdesk again. We are keeping a close eye on the situation. We apologise for the inconvenience.
Posted Mar 16, 2026 - 15:24 CET
Investigating
We are currently experiencing disruptions with logging in to My TOPdesk.
We are aware of the problem and are working on a solution.
Our apologies for the inconvenience. At the time of writing this we are not able to give you an estimate on when your environment will be available. The next update will be provided as events warrant until the issue has been resolved.
E-mail updates will be sent right away when the issue has been resolved. You can subscribe on the status page (https://status.topdesk.com) for additional updates.