SaaS disruption
Incident Report for TOPdesk SaaS Status page
Postmortem

On Thursday May 28th from 12:15 (12:15 PM) CEST we received several reports of customers having difficulties accessing their environments in our UK1 datacenter.

Our initial research into possible causes showed an outage at British Telecom at that time as well, which proved to be unrelated.

Further research pointed towards the authentication service being affected. Subsequently, at 13:30 (01:30 PM) CEST the issue was escalated to the responsible development team who confirmed an issue with our authentication service (the passlayer).

At 14:31 (02:31 PM) CEST the issue was resolved, and customers could log in again.
We continued to monitor the situation and no remaining issues were identified.

Root cause

During a routine rollover of a new version in our authentication system, part of the system became unresponsive due to a transient network error. This prevented the update to finish successfully. ​

Follow up actions

We have been working on improving the process around authentication service upgrades, in order to ensure that our system handles these problems in a more robust way.

Our apologies for the delay in publishing this RCA. This was due to a miscommunication between the team investigating and the team in charge of publishing the RCA. We have reassessed our major incident communication processes to ensure such delays will not occur in the future.

Posted Jul 21, 2020 - 16:28 CEST

Resolved
We've identified and resolved an issue in our authentication system. All systems are again operational.

Please contact TOPdesk Support if you are still experiencing any issues while working in TOPdesk.
Posted May 28, 2020 - 14:31 CEST
Update
We are investigating a possible issue with the internal authentication system.
Posted May 28, 2020 - 14:00 CEST
Update
In parallel to BT issues we're investigating possibly affected components on our side as well. We will post an update as soon as possible.
Posted May 28, 2020 - 13:49 CEST
Update
We received reports about outages at British Telecom. We're investigating if those are related.
Posted May 28, 2020 - 12:55 CEST
Investigating
We are currently experiencing problems in our UK1 datacenter.
As a result your TOPdesk environment may not be available.

We are aware of the problem and working on a solution.

Our apologies for the inconvenience. The current status can be found on our TOPdesk Status Page: https://status.topdesk.com

To inform TOPdesk you are affected by this issue, please visit https://my.topdesk.com/tas/public/ssp/ . Please refer to incident 20 05 6949.
Posted May 28, 2020 - 12:40 CEST
This incident affected: UK1 SaaS hosting location.