RESOLVED: Degraded performance on UK1C03 hosting location
Incident Report for TOPdesk SaaS Status page
Postmortem

The incident on March 13th, 14th, 20th & 21st was triggered by an excessive load on the SQL server caused by frequent, heavy queries. This resulted in degraded performance and impacted the environments for other tenants on the UK1C03 hosting location. Customers reported degraded performance over a period of time, and after a thorough investigation, we worked with the customer in question to disable the integration causing the high number of API calls to ease the load on the SQL server and restore performance and stability for customers on UK1C03. After doing this we immediately observed the SQL server returning to normal functionality. The major incident was closed at 17:30 GMT after continuously monitoring normal behavior. We have subsequently tested this integration to confirmed that it produces inefficient queries and escalated this to our Development / Integration team. They have confirmed this behavior and are currently exploring ways to update this integration to ensure this does not happen again.

Posted Apr 02, 2024 - 08:24 CEST

Resolved
We believe we have isolated the root cause, and have reached out to the appropriate party to remedy this problem. Please reach out to Support if you have any further questions.
Posted Mar 20, 2024 - 18:30 CET
Update
We believe we have isolated the root cause, and have reached out to the appropriate party to remedy this problem. Please reach out to Support if you have any further questions.
Posted Mar 20, 2024 - 18:05 CET
Update
Our Technical Support and Development teams are continuing to investigate this issue and have pinpointed what we believe to be the root cause. We will provide a further update on this as soon as we are able to confirm this though.

Apologies for the ongoing inconvenience.
Posted Mar 20, 2024 - 16:43 CET
Investigating
We are currently experiencing problems on the UK1 hosting location, more specific container 03. As a result your TOPdesk may experience degraded performance.

We are aware of the problem and are working on a solution.

Our apologies for the inconvenience. At the time of writing this we are not able to give you an estimate on when your environment will return to normal. The current status can be found on our TOPdesk Status Page: https://status.topdesk.com

To inform TOPdesk you are affected by this issue, please visit https://my.topdesk.com/tas/public/ssp/ . Please refer to incident TDR24 03 7136.
Posted Mar 20, 2024 - 16:13 CET
This incident affected: UK1 SaaS hosting location.