RESOLVED: Problems with Action Sequences on NL3 Hosting Location
Incident Report for TOPdesk SaaS Status page
Postmortem

During an upgrade, a few instances were not coming back online, which led to the discovery that the TOPdesk messaging system was allocated insufficient memory. Although initial attempts were made to increase the memory, the problem persisted, affecting customer Action Services. The issue was complicated by the database server running out of disk space and the roll-out of a new version of Action Service to handle the queue of actions awaiting to be executed. Despite these challenges, the team was able to temporarily resolve the issue. However, the change to increase the TOPdesk messaging system memory was unexpectedly reverted, causing further problems. After adjusting some settings and ensuring messages were picked up, the issue seemed resolved. Yet, later in the day, problems with the messaging system led to a build-up of unsent messages. The team then identified a case where the bugfix roll-out did not work as intended and applied a fix. 

 

The incident highlighted the need for better system metrics, alert mechanisms, and communication protocols. Measures have been taken by various development teams to prevent a recurrence and improve the system's response to such incidents.

Posted Feb 02, 2024 - 13:26 CET

Resolved
Following a thorough and close monitoring of the situation, we can affirm that the issue has been successfully resolved.

Should you require further assistance, please do not hesitate to contact support.

Thank you for your patience and understanding.
Posted Jan 16, 2024 - 13:22 CET
Update
The processing of action sequences queue is currently taking more time than anticipated. We are actively monitoring the situation and want to reassure you that all conditions have returned to normal. Your patience and understanding during this period are sincerely appreciated.
Posted Jan 16, 2024 - 11:52 CET
Monitoring
We have identified the root cause, implemented a solution, and are now monitoring the situation. We want to emphasize to customers not to manually retrigger action sequences, as they will be processed automatically as the issue is resolved. Please allow up to 30 minutes for the resolution to take effect.
Posted Jan 16, 2024 - 10:25 CET
Update
We are actively continuing our investigation to pinpoint the root cause.

We will provide an update as soon as there are any findings in the investigation
Posted Jan 16, 2024 - 09:46 CET
Investigating
We are currently having issues with of action sequences on hosting location NL3.

We will post an update in 30 minutes.

Our apologies for the inconvenience. At the time of writing this we are not able to give you an estimate on when your environment will be available. We aim to update this status page every 30 minutes until the issue has been resolved.

E-mail updates will be sent when the issue has been resolved. You can subscribe on the status page (https://status.topdesk.com) for additional updates.

To inform TOPdesk you are affected by this issue, please visit https://my.topdesk.com/tas/public/ssp/ . Please refer to incident TDR24 01 4564.
Posted Jan 16, 2024 - 09:04 CET
This incident affected: NL3 SaaS hosting location.