RESOLVED: Slowness at hosting location CA1

Incident Report for TOPdesk SaaS Status page

Resolved

We are pleased to inform you that the issue has been resolved. All services are now operating normally, and access to resources in the CA1 region is now restored. This major will now be closed.
Posted Mar 03, 2025 - 21:18 CET

Update

A new update from Microsoft indicates that they have identified the issue and have taken steps to mitigate the problem. Internally we have also seen improvements with the latency data coming from Microsoft, we will continue to monitor and ensure that performance returns to optimal levels. 

You can stay up to date with the issue on the Microsoft Azure status page... https://azure.status.microsoft/en-us/status
Posted Mar 03, 2025 - 20:05 CET

Update

After continued investigation our services remain fully operational and healthy, our cloud provider Microsoft Azure recently made us aware of issues they are experiencing... 

"Investigating reports of Azure issues in Canada and East US
We're aware of reports of some issues accessing Azure resources in Canada and East US regions that we're currently investigating. We'll provide additional information as we become aware of it.
This message was last updated at 18:22 UTC on 03 March 2025"

You can keep up to date with their status page here... https://azure.status.microsoft/en-us/status
Posted Mar 03, 2025 - 19:37 CET

Update

Preliminary investigations indicate that the slowness is caused by external factors. Our services remain fully operational, and we are able to reach all internal environments without any issues. We will continue to monitor the situation closely.
Posted Mar 03, 2025 - 18:58 CET

Update

Update: 

We are currently investigating these issues with multiple teams to identify the root of this issue.
Posted Mar 03, 2025 - 18:50 CET

Investigating

We are currently experiencing disruptions with one of our services on CA1 . As a result your TOPdesk environment may not be available or respond slowly

We are aware of the problem and are working on a solution.

To help us troubleshoot this issue, please add the following information to your ticket when you are affected by this disruption:

- The date and time of the last reproduction of this issue
- The username of the user that reproduced this issue
- A description of what the user was doing in TOPdesk
- Browser activity and network traffic logs in a .HAR file, see KI 11015 on how to gather this information.

Please contact TOPdesk Support after submitting an incident, so we can store additional logfiles to investigate this.

Our apologies for the inconvenience. At the time of writing this we are not able to give you an estimate on when your environment will be available. We aim to update this status page every 30 minutes until the issue has been resolved.

E-mail updates will be sent when the issue has been resolved. You can subscribe on the status page (https://status.topdesk.com) for additional updates.

To inform TOPdesk you are affected by this issue, please visit My TOPdesk.
Posted Mar 03, 2025 - 18:13 CET
This incident affected: CA1 SaaS hosting location.