SaaS disruption EU1
Incident Report for TOPdesk SaaS Status page
Postmortem

At 14:57 CET on November 3rd 2020 our monitoring system reported a problem in the authentication service used by TOPdesk in the EU1 hosting location. The service runs over multiple ‘pods’, but couldn’t determine which of these pods were available. This caused traffic to be routed to the wrong place, causing customers to experience connection issues while working in TOPdesk.

Between 15:10 and 15:25 all pods hosting the authentication service were restarted in order to resolve the problem. At 15:25 the problem was resolved.

**
Root cause**

We were unable to determine why some of the pods running the authentication service had become unavailable. Our investigation did identify 3 issues in the management system for the authentication service that could have caused this problem. 1 of these issues has now been resolved, for the other 2 issues a solution is being tested (last updated 27-11-2020). We do not expect this problem to reoccur when all 3 issues have been resolved.

**
Follow-up actions**

We’re still working to resolve some of the issues identified during our investigation of the root cause of this problem. Next to these issues, we’ve updated our documentation on how to resolve the problem, and are working to add additional metrics to our monitoring system to better detect the situation before it affects the customer experience.

Posted Nov 27, 2020 - 11:33 CET

Resolved
Between 15:00 and 15:30 CET several customers experienced error pages while working in TOPdesk. Since then we have not received any new reports of errors while working in TOPdesk. As no new reports have come in, and several customers indicated the issue is resolved, we'll mark this incident as resolved.

We expect to post a root cause analysis on the status page within 1 week
Posted Nov 03, 2020 - 15:37 CET
Monitoring
The problem has been resolved. If you still experience problems, please get in touch with Support
Posted Nov 03, 2020 - 15:31 CET
Update
A problem with the authentication service has been identified and is being worked on
Posted Nov 03, 2020 - 15:26 CET
Update
First investigations are pointing towards a problem with the authentication service
Posted Nov 03, 2020 - 15:18 CET
Investigating
We are currently experiencing problems on
- the EU1 hosting location. As a result your TOPdesk environment may not be available.

We are aware of the problem and working on a solution.


Our apologies for the inconvenience. We aim to update this status page every 30 minutes until the issue has been resolved.

E-mail updates will be sent when the issue has been resolved. You can subscribe on the status page (https://status.topdesk.com) for additional updates.

To inform TOPdesk you are affected by this issue, please visit https://my.topdesk.com/tas/public/ssp/ . Please refer to incident TDR20 11 922.
Posted Nov 03, 2020 - 15:09 CET
This incident affected: EU1 SaaS hosting location.