UK1 disruption
Incident Report for TOPdesk SaaS Status page
Postmortem

On the morning of June 17th, 2024, at approximately 10:15 CET, we began receiving reports from our customers about being unable to send emails. Additionally, some customers reported experiencing degraded performance. All of these reports originated from SaaS environments hosted in the UK1 data center.

Upon receiving these reports, our engineers immediately began an investigation and quickly identified the cause: long-running queries on the SQL server. A fix was implemented at 11:15 CET, leading to an immediate improvement.

We are pleased to report that the main issue was fully resolved by 11:50 CET. The entire disruption, from the initial report to the final resolution, lasted approximately one hour.

Posted Sep 20, 2024 - 17:25 CEST

Resolved
After careful monitoring following the applied solution, we are pleased to inform you that the issue has been completely resolved.

We will proceed to evaluate this issue internally. Upon its completion, a Root Cause Analysis (RCA) will be posted on our status page for your reference.

If you continue to experience any issues, kindly reach out to our support team for assistance. We appreciate your patience and understanding in this matter.
Posted Jun 17, 2024 - 11:49 CEST
Identified
Our engineers have identified the cause and a fix is being implemented.

We will post another update as soon as possible.
Posted Jun 17, 2024 - 11:19 CEST
Investigating
We are currently experiencing problems on our UK1 hosting location. As a result, outgoing mails may be impacted and and some users could also experience performance issues.

We are aware of the problem and are working on a solution.

Our apologies for the inconvenience. At the time of writing this we are not able to give you an estimate on when your environment will be available. The current status can be found on our TOPdesk Status Page: https://status.topdesk.com
Posted Jun 17, 2024 - 10:55 CEST
This incident affected: UK1 SaaS hosting location.