Error pages while working in TOPdesk
Incident Report for TOPdesk SaaS Status page
Postmortem

On Monday November 2nd around 10:25 CET several customers reported error pages while working in TOPdesk. The issue was resolved in 10 minutes.

Root cause

Our Content Delivery Network (CDN) provider had a CPU issue on their Brussels (BRU) hosting location. All traffic to TOPdesk environments routed through that hosting location had a chance of receiving an error page, as not all traffic could be processed properly.

Follow-up actions

We’re working with the CDN provider to improve our cooperation and communication during disruptions, to be better able to provide timely information to our customers when a problem occurs.

Posted Nov 05, 2020 - 14:32 CET

Resolved
Between 10:25 and 10:30 CET several customers experienced error pages while working in TOPdesk. Since then we have not received any new reports of errors while working in TOPdesk.

As no new reports have come in, and several customers indicated the issue is resolved, we'll mark this incident as resolved on our status page. We're still working with the Content Delivery Network supplier to investigate the root cause of this problem. We expect to post a root cause analysis on the status page in 1 week.
Posted Nov 02, 2020 - 12:04 CET
Update
The issue lasted only a few minutes. We've contacted our supplier for more information.
Posted Nov 02, 2020 - 11:17 CET
Monitoring
We haven't found any issues in our systems, and our suppliers haven't published any problems on their status pages. Several customers reported that the issues were no longer present.

We're contacting our suppliers for more information.
Posted Nov 02, 2020 - 11:14 CET
Update
All our European hosting locations appear to be affected. This indicates a problem at our Content Delivery Network.

We're still investigating the root cause of this problem and will update this page when more information is available.
Posted Nov 02, 2020 - 10:46 CET
Investigating
We are currently experiencing problems on our NL3 hosting location. Several customers report getting (Cloudflare) error pages while working in TOPdesk.

We are aware of the problem and working on a solution.

Our apologies for the inconvenience. We aim to update this status page every 30 minutes until the issue has been resolved.

E-mail updates will be sent when the issue has been resolved. You can subscribe on the status page (https://status.topdesk.com) for additional updates.

To inform TOPdesk you are affected by this issue, please visit https://my.topdesk.com/tas/public/ssp/ . Please refer to incident TDR20 11 096.
Posted Nov 02, 2020 - 10:40 CET
This incident affected: EU1 SaaS hosting location and NL3 SaaS hosting location.