At this time the EU1co3 is now back to full operational state without any performance issues, we will close this major.
Posted Jul 02, 2026 - 20:57 CEST
Monitoring
We have identified the issue and made actions to mitigate the cause.
The EU1co3 is now back to full operational state without any performance issues
We will continue to closely monitor the situation to ensure the service remains stable.
Posted Jul 02, 2026 - 13:42 CEST
Investigating
We are currently experiencing disruptions affecting customers hosted in EU1, resulting in performance issues.
As a result, your TOPdesk environment may be slow or temporarily unavailable.
We are aware of the problem and are working on a solution.
Our apologies for the inconvenience. At the time of writing, we are not able to provide an estimate for when normal service will be restored. We aim to update this status page every 30 minutes until the issue has been resolved.
E-mail updates will be sent when the issue has been resolved. You can subscribe on the status page (https://status.topdesk.com) for additional updates.
To inform TOPdesk you are affected by this issue, please visit My TOPdesk.
Posted Jul 02, 2026 - 11:03 CEST
This incident affected: EU1 SaaS hosting location.