RESOLVED: SaaS disruption EU1 issues with email server
Incident Report for TOPdesk SaaS Status page
Resolved
We are pleased to inform you that the major issue affecting our EU1 hosting location have been resolved.

After thorough investigation, we confirmed that the disruption was due to our email server being temporarily blacklisted. Please note, this issue only affected customers using TOPdesk's own mail server.

Further investigation into our logs has indicated that the first instance of an email not being delivered occurred on the 9th of April shortly after 18:00 until 12:45 10th of April. We will continue to assess the logs to identify the precise timeframe of the disruption.

To identify potentially lost emails during this period, we encourage customers to use TOPdesk's selection tool. This is outlined in an existing Knowledge Item KI 8495: Selections: sent e-mails from an incident card, which has been recently expanded to include usage on how to retrieve an overview of cards from which mails have been sent within a specific time frame. For extra clarity, this will also work with emails sent through the API, but only if the checkbox is checked that links this mail to the card it was triggered from.

Moving forward, we will assemble a team to conduct a thorough Root Cause Analysis (RCA) to evaluate the way TOPdesk uses the email server. The results of this analysis will be published on the same status page. The objective is to avoid such occurrences in the future and to enhance our service delivery.

Our support department is available to provide further assistance if needed.

We sincerely apologize for any inconvenience this may have caused and appreciate your understanding during this situation. If you have any further questions or concerns, please do not hesitate to contact us.
Posted Apr 10, 2024 - 16:23 CEST
Monitoring
We've received reports from customers and have conducted successful tests ourselves confirming that email functionality is back to normal.

We suspect the initial disruption may have been due to our email server being temporarily blacklisted, which prevented some emails from being delivered. The blockage appears to have been lifted, but we are closely monitoring the situation to ensure stability.

While it's difficult to confirm the exact cause at this moment, we're continuing to investigate. If our suspicions hold true, we will investigate this thoroughly and detail the findings in our Root Cause Analysis (RCA).

For now, our main focus is on monitoring the situation to prevent further disruptions.
Posted Apr 10, 2024 - 12:56 CEST
Update
Our team has identified a potential cause of the email delivery issue affecting our EU1 hosting location. We're currently investigating solutions.

The first report of this issue came in at 8:52AM and the most recent at 11:15AM.

We will provide another update in approximately an hour, or sooner if any relevant information emerges.
Posted Apr 10, 2024 - 11:41 CEST
Investigating
We are currently experiencing problems on our EU1 hosting location. As a result your TOPdesk environment may not be able to deliver emails.

We are aware of the problem and are working on a solution.

Our apologies for the inconvenience. At the time of writing this we are not able to give you an estimate on when your environment will be available. We aim to update this status page every 30 minutes until the issue has been resolved.

E-mail updates will be sent when the issue has been resolved. You can subscribe on the status page (https://status.topdesk.com) for additional updates.

To inform TOPdesk you are affected by this issue, please visit https://my.topdesk.com/tas/public/ssp/ . Please refer to incident TDR24 04 2880.
Posted Apr 10, 2024 - 11:01 CEST
This incident affected: EU1 SaaS hosting location.