RESOLVED: SaaS disruption EU1 (database issues)

Incident Report for TOPdesk SaaS Status page

Postmortem

On the 21st of July 2022, customers hosted in the EU1 datacenter were unable to access their environments.

The outage was caused by a human error at our supplier Microsoft Azure. The cache with metadata of all databases was no longer available to the regional gateway processes. This lead to TOPdesk environments no longer being able to connect to their database.
Our supplier will be implementing several changes both in their processes and setup to prevent this issue from reoccurring.

Posted Jul 27, 2022 - 14:42 CEST

Resolved

Based on our monitoring, database functionality has been restored. The disruption has been fully resolved.

Please contact TOPdesk Support if you are still running into hosting issues.
Posted Jul 21, 2022 - 10:51 CEST

Monitoring

Database functionality appears to have been restored, and your environment should be available again. We are checking to see if there are still any lingering issues. Should you still experience any issues, please contact our support department.
Posted Jul 21, 2022 - 08:33 CEST

Update

Our hosting provider still reports the database functionality as broken. Tests from our side also revealed that connectivity has not been restored yet.

We will continue testing and aim to restore functionality as soon as possible. Do note, however, that we are fully dependent on our provider for a solution. Since they have not given us an estimate, at this point in time we can also not give an estimate on when environments will be available again.
Posted Jul 21, 2022 - 08:17 CEST

Investigating

We are currently experiencing problems on our EU1 hosting location. As a result your TOPdesk environment may not be available.

This issue is caused by our hosting provider having issues with the managed database they supply. They are aware of the problem and are working on a solution.

Not having a database means the TOPdesk software is unable to function. As soon as the hosting provider reports that functionality has been restored, we will start taking steps to ensure a quick recovery from this incident.

Our apologies for the inconvenience. We aim to update this status page every 30 minutes until the issue has been resolved.

E-mail updates will be sent when the issue has been resolved. You can subscribe on the status page (https://status.topdesk.com) for additional updates.

To inform TOPdesk you are affected by this issue, please visit https://my.topdesk.com/tas/public/ssp/ . Please refer to incident TDR22 07 6457.
Posted Jul 21, 2022 - 07:31 CEST
This incident affected: EU1 SaaS hosting location.