SaaS disruption in the BR1 data center
Incident Report for TOPdesk SaaS Status page
Resolved
It really is everything steady again.

This issue had the same cause of what's being felt during the past month and what is also being felt in our European hosting location. We don't know the root cause yet, but we are often in contact with Microsoft specialists to resolve it with a high priority.

If you are still feeling any kind of slowness, please don't hesitate to contact our TOPdesk Support.
Posted Dec 21, 2020 - 19:21 CET
Update
We're still working to resolve this issue.

It seems everything is working fine again but we are still making sure of it.
Posted Dec 21, 2020 - 18:58 CET
Investigating
We are currently experiencing problems on the BR1 hosting location. As a result your TOPdesk environment may not be available.

We are aware of the problem and working on a solution.

Our apologies for the inconvenience. We aim to update this status page every 30 minutes until the issue has been resolved.

E-mail updates will be sent when the issue has been resolved. You can subscribe on the status page (https://status.topdesk.com) for additional updates.

To inform TOPdesk you are affected by this issue, please visit https://my.topdesk.com/tas/public/ssp/ . Please refer to incident TDR20 12 6938.
Posted Dec 21, 2020 - 18:03 CET
This incident affected: BR1 SaaS Hosting location.