My TOPdesk is temporarily unavailable
Incident Report for TOPdesk SaaS Status page
Resolved
We have restarted the My TOPdesk environment and it is reachable again.
Posted Dec 07, 2020 - 11:13 CET
Investigating
We are investigating the issue and are working to get our services back as quickly as possible
Posted Dec 07, 2020 - 11:07 CET
This incident affected: My TOPdesk.