My TOPdesk is temporarily unavailable
Incident Report for TOPdesk SaaS Status page
Resolved
The issue has been resolved, we will continue monitoring the situation.
Posted Nov 18, 2020 - 17:49 CET
Investigating
We are investigating the issue and are working to get our services back as quickly as possible
Posted Nov 18, 2020 - 17:34 CET
This incident affected: My TOPdesk.