My TOPdesk is temporarily unavailable
Incident Report for TOPdesk SaaS Status page
Resolved
MY TOPdesk is available again.
Posted Oct 12, 2020 - 09:12 CEST
Investigating
We are investigating the issue and are working to get our services back as quickly as possible
Posted Oct 12, 2020 - 09:05 CEST
This incident affected: My TOPdesk.