My TOPdesk and TOPdesk Support NL unavailable
Incident Report for TOPdesk SaaS Status page
Resolved
Our engineers have been monitoring our services and have concluded the disruption to be fully resolved.

Please contact TOPdesk Support if you are still running into hosting issues.
Posted Jul 05, 2022 - 13:12 CEST
Update
We are continuing to monitor for any further issues.
Posted Jul 05, 2022 - 11:26 CEST
Update
The disruption of our services was caused by a power failure affecting servers in the hosting location used for TOPdesk NL office equipment.

With this, the following services were unavailable:
• My TOPdesk
• The Dutch Support Line

This disruption did not affect customer (SaaS) environments.

The total outage took around 3 hours.

The cause of this power failure will be investigated to prevent the issue from reoccurring.

Our apologies for the inconvenience.
Posted Jul 05, 2022 - 11:23 CEST
Monitoring
All our services, including my.topdesk.com are back online.

We will continue to monitor the situation closely.

A summary with follow shortly.
Posted Jul 05, 2022 - 11:10 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 05, 2022 - 09:49 CEST
Update
Our Dutch support number is now available again.

We are still working towards a fix to bring my.topdesk.com online as quickly as possible.
Posted Jul 05, 2022 - 09:48 CEST
Update
We have implemented a temporary fix for our phone. Our Dutch number is still unavailable, but it is possible to contact us using one of the alternative phone numbers listed on https://page.topdesk.com/contact-support

We are aware of the outage of my.topdesk.com, and we are still working towards a fix to bring our services online as quickly as possible.
Posted Jul 05, 2022 - 09:15 CEST
Investigating
My TOPdesk and the phone line for TOPdesk Support in the Netherlands are currently unavailable. Out team is aware of the issue and is working on a solution.

If you need to reach out to TOPdesk Support during this disruption, please use our e-mail address, or one of the alternative phone numbers listed on https://page.topdesk.com/contact-support
Posted Jul 05, 2022 - 08:51 CEST
This incident affected: My TOPdesk.