My TOPdesk is temporarily unavailable
Incident Report for TOPdesk SaaS Status page
Resolved
The authentication issue has been resolved, My TOPdesk is available again.
Posted Sep 06, 2021 - 09:46 CEST
Investigating
There is currently an issue with authentication for My TOPdesk. We are investigating the issue and are working to get our services back as quickly as possible
Posted Sep 06, 2021 - 09:00 CEST
This incident affected: My TOPdesk.