Mail relay issue in the US1 datacenter
Incident Report for TOPdesk SaaS Status page
Postmortem

On August 21st 2020 at 07:33 UTC our US1 mail relay server experienced a delay while sending emails. The issue lasted for approximately 3 hours.

This issues was caused by a pending abuse notification that was not acted on in time. The abuse notification originated from an e-mail recipient at one of our customers. The customer had not set their SPF record correctly, causing their outgoing e-mails to be marked as spam by the recipient.

To prevent this issue we took several actions to ensure that abuse notifications are directly visible to our SaaS team. We also contacted the customer to make sure they set their SPF record correctly.

Posted Sep 04, 2020 - 15:54 CEST

Resolved
The problem with the US1 mail relay server is solved and is sending out e-mails as expected.
Posted Aug 22, 2020 - 00:26 CEST
Monitoring
We have identified the issue together with our hosting provider and applied a fix. At the moment all queued e-mails on our US1 mail relay are being sent out. Note that this process can take a while.
Posted Aug 22, 2020 - 00:02 CEST
Investigating
US1 customers who are using our email relay server can notice a delay while sending emails out from TOPdesk. We are aware of the problem and working on a solution. We are in contact with our hosting provider to find a solution.

All emails are in a queue and will be delivered as soon as the issue is resolved.

To inform support you are affected by this issue, please visit https://my.topdesk.com/tas/public/ssp/ . Please refer to incident 20 08 5757.
Posted Aug 21, 2020 - 22:56 CEST
This incident affected: US1 SaaS hosting location.