Disruption in EU1 hosting location
Incident Report for TOPdesk SaaS Status page
Resolved
The database performance issues on the EU1 Azure platform have been resolved.

We have manually checked a few environments and concluded that the performance is back to the normal standard.

If your performance is still affected, please update your ticket on my.topdesk.com.
Posted Sep 03, 2020 - 15:31 CEST
Update
Engineers at Microsoft Azure have have applied a fix that should resolve this problem. They are still in the process of verifying the mitigation.
Posted Sep 03, 2020 - 13:57 CEST
Identified
The performance problems are caused by the database services hosted on our EU1 Azure hosting location.

The issues seem to be related to database problems which started around 11:30 CET.

We are closely monitoring any updates from Azure and will update our major incident and status page when we have more information.
Posted Sep 03, 2020 - 12:47 CEST
Update
We are investigating issues of a database service affecting a small part of our environments causing performance problems.
Posted Sep 03, 2020 - 12:25 CEST
Investigating
We are investigating performance problems on our EU1 hosting location.

To inform TOPdesk you are affected by this issue, please visit https://my.topdesk.com/tas/public/ssp/ . Please refer to incident TDR20 09 990.
Posted Sep 03, 2020 - 12:21 CEST
This incident affected: EU1 SaaS hosting location.