My TOPdesk is temporarily unavailable
Incident Report for TOPdesk SaaS Status page
Resolved
This incident has been resolved.
Posted Nov 26, 2020 - 09:09 CET
Investigating
We are investigating the issue and are working to get our services back as quickly as possible
Posted Nov 26, 2020 - 06:30 CET
This incident affected: My TOPdesk.