My TOPdesk authentication service unavailable.
Incident Report for TOPdesk SaaS Status page
Resolved
The authentication service issue was related to the previous network problem we had earlier today.

The issue is resolved and customers are able to login again into https://my.topdesk.com
Posted Jul 15, 2020 - 22:14 CEST
Investigating
Our internal TOPdesk environment, My.TOPdesk.com, is currently having issues with the authentication service.

Customers can still contact us via email or by phone, for contact details please visit https://page.topdesk.com/contact-support
Posted Jul 15, 2020 - 21:11 CEST
This incident affected: My TOPdesk.