My TOPdesk is temporarily unavailable
Incident Report for TOPdesk SaaS Status page
Resolved
Due to a memory issue My TOPdesk was temporarily unavailable. After a restart it is available again.
Posted Oct 12, 2020 - 16:45 CEST
Investigating
We are investigating the issue and are working to get our services back as quickly as possible
Posted Oct 12, 2020 - 16:39 CEST
This incident affected: My TOPdesk.