My.TOPdesk.com currently unavailable.
Incident Report for TOPdesk SaaS Status page
Resolved
The issue has been resolved, My.TOPdesk.com is available again.

If you encounter any issues please contact us by phone.
Posted Jul 17, 2020 - 14:01 CEST
Investigating
Our internal TOPdesk environment, My.TOPdesk.com, is currently unavailable.

We are investigating the issue.
Posted Jul 17, 2020 - 13:33 CEST
This incident affected: My TOPdesk.