My TOPdesk unavailable
Incident Report for TOPdesk SaaS Status page
Resolved
The My TOPdesk environment is reachable again.
Posted Nov 26, 2020 - 14:12 CET
Investigating
My TOPdesk is currently unavailable. TOPdesk is aware of the problem and is investigating the situation.
Posted Nov 26, 2020 - 14:10 CET
This incident affected: My TOPdesk.