RESOLVED: Service disruption my.topdesk

Incident Report for TOPdesk SaaS Status page

Resolved

The availability issues on My.TOPdesk are solved.
Our teams have found the issue and implemented a fix. My.TOPdesk is available and operational for your requests.

All tickets linked to the major will now be closed. If you experience any lingering problems please contact us through your known channels.
Thank you for your patience,

TOPdesk Support
Posted May 21, 2025 - 14:56 CEST

Update

The availability issues on My.TOPdesk are solved.
Our teams have found the issue and implemented a fix. My.TOPdesk is available and operational for your requests.

All tickets linked to the major will now be closed. If you experience any lingering problems please contact us through your known channels.
Thank you for your patience,

TOPdesk Support
Posted May 21, 2025 - 14:54 CEST

Investigating

We are currently experiencing disruptions with one of our services. As a result your my.topdesk.com may not be available.

We are aware of the problem and are working on a solution.

If you require support for your TOPdesk environment, please contact TOPdesk Support by phone or via email at support@topdesk.com. Once we have more information, we will update this page.

To inform TOPdesk you are affected by this issue, please visit https://my.topdesk.com/tas/public/ssp/ . Please refer to incident TDR25 05 4864.
Posted May 20, 2025 - 10:31 CEST
This incident affected: Functionality malfunction.