Some TEST environments unreachable in several hosting locations
Incident Report for TOPdesk SaaS Status page
Postmortem

A bug in our SaaS tooling caused a necessary view to be dropped upon database recreation, for instance during moves or reseeds. This only occurred when targeting a specific part of our infrastructure. This in turn caused a database cleanstep to fail, breaking TOPdesk during startup. The necessary steps have been taken to prevent issues like these from reoccuring in the future.

We feel it's important to mention that the staged rollout setup prevented this bug from affecting production environments.

Posted Oct 16, 2020 - 15:03 CEST

Resolved
All test environments are back online.

There was no impact on production environments. TOPdesk will make sure the root cause is resolved before this version is deployed to production environments.
Posted Oct 07, 2020 - 14:15 CEST
Update
A temporary fix has been implemented for all affected test environments. We are restarting the affected test environments to bring them back online. We expect all test environments to be available at 14:00 CEST.
Posted Oct 07, 2020 - 13:04 CEST
Update
The root cause of the failed updates has been found. We're working on a temporary solution to get all test environments back online. We think the test environments will be back online in a few hours.

Continuous Deployment upgrades for all production environments will be postponed until the root cause has been resolved for all environments.
Posted Oct 07, 2020 - 11:17 CEST
Update
Last night an upgrade for all test environments with the Continuous Deployment update group was scheduled. In some cases the upgrade of test environments failed. We're investigating what these test environments have in common, why this did not occur during our internal tests, and what can be done to resolve the issue.

If your test environment is offline and you urgently need to use it today, please call TOPdesk Support.
Posted Oct 07, 2020 - 10:43 CEST
Investigating
We are currently experiencing availability issues with TOPdesk SaaS test environments in various hosting locations. As a result your TOPdesk SaaS test environment may not be available. 

TOPdesk is aware of the problem and working on a solution. Our apologies for the inconvenience.

To inform TOPdesk you are affected by this issue, please visit https://my.topdesk.com/tas/public/ssp/ . Please refer to incident TDR20 10 1856.
Posted Oct 07, 2020 - 10:42 CEST
This incident affected: NL2 SaaS hosting location, NL3 SaaS hosting location, US1 SaaS hosting location, UK1 SaaS hosting location, CA1 SaaS hosting location, AU1 SaaS hosting location, EU1 SaaS hosting location, and BR1 SaaS Hosting location.