Canada hosting location unreachable

Incident Report for TOPdesk SaaS Status page

Resolved

This incident has been resolved.
Posted Jun 06, 2026 - 22:23 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 06, 2026 - 22:23 CEST

Update

All environments are accessible again. Root cause analysis will be published within a week.
Posted Jun 06, 2026 - 22:19 CEST

Update

We have identified an issue in the load balancer for the services cluster. We are working on resolving this issue.
Posted Jun 06, 2026 - 22:04 CEST

Update

We are continuing to investigate this issue.
Posted Jun 06, 2026 - 21:51 CEST

Update

We are continuing to investigate this issue.
Posted Jun 06, 2026 - 21:17 CEST

Update

We are continuing to investigate this issue.
Posted Jun 06, 2026 - 20:40 CEST

Update

We are currently investigation the cause of this outage. We will keep you updates every 30 minutes
Posted Jun 06, 2026 - 20:28 CEST

Update

We are continuing to investigate this issue.
Posted Jun 06, 2026 - 20:27 CEST

Investigating

TOPdesk environment unreachable for hosting location in Canada
Posted Jun 06, 2026 - 20:26 CEST
This incident affected: CA1 SaaS hosting location.