My TOPdesk is temporarily unavailable
Incident Report for TOPdesk SaaS Status page
Resolved
The issue with our authentication server has been resolved. My TOPdesk can now be reached again.
Posted Oct 20, 2021 - 10:50 CEST
Investigating
We are investigating the issue and are working to get our services back as quickly as possible
Posted Oct 20, 2021 - 09:57 CEST
This incident affected: My TOPdesk.