The issue where Operators where unable to use TOPdesk who had the Adobe Extension active in Chrome, is tested and ready. Our fix will be introduced in TOPdesk version 16.06.004.
When your TOPdesk has reached this version, you can turn the Extension on again in the Chrome Extension.
Our apologies for the inconvenience.
Posted Jun 05, 2026 - 09:54 CEST
Update
Update: a workaround has been implemented, and the fix will be rolled out with the next release. The next version will usually be release within the next week.
Posted Jun 03, 2026 - 13:42 CEST
Investigating
We are currently experiencing disruptions with the Adobe PDF plugin version 26.5.2.0 Customers experience issues login in as an Operator. The page will infinitely buffer.
Turning off the browser plugin/extension and restarting your browser will resolve the issue for now. We will investigate further and will update you on the fix.
Our apologies for the inconvenience. Please find the latest updates on our TOPdesk Status Page: https://status.topdesk.com