Connection issues in UK
Incident Report for TOPdesk SaaS Status page
Postmortem

On February 10th, 2020 around 09:30AM BST several customers reported problems accessing their TOPdesk environment hosted in the UK datacenter. About 10% of our UK hosted customers reported problems while working in TOPdesk.

We've conducted several tests and analysed our monitoring systems, but have been unable to reproduce the problems mentioned.

At 10:00AM several customers had confirmed that TOPdesk environments are accessible via mobile phones, indicating a problem at an Internet Service Provider (ISP) in the UK.

Since there is no indication that an issue occurred in the TOPdesk SaaS network or at our subprocessors, no follow-up actions have been scheduled.

Posted Feb 18, 2020 - 13:57 CET

Resolved
This morning several customers reported problems accessing their TOPdesk environment hosted in the UK datacenter. We've conducted several tests and analysed our monitoring systems, but have been unable to reproduce the problems mentioned.

Several customers have confirmed that TOPdesk environments are accessible via mobile phones, indicating a problem at an Internet Service Provider (ISP) in the UK. Please contact your ISP if you are still experiencing any issues.
Posted Feb 10, 2020 - 11:13 CET
Monitoring
Status changed to operational, as nothing indicates that these problems originate in our network. TOPdesk will continue to monitor the situation.
Posted Feb 10, 2020 - 10:51 CET
Update
TOPdesk is unable to reproduce the issues mentioned by customers from our Dutch and UK offices. Our monitoring systems do not show any problems with UK environments.

The issue is most likely caused by a problem at a UK internet service provider (ISP). Customers that experience slowness can check if their TOPdesk environment is reachable via mobile phones, and can contact their ISP to see if they are aware of any ongoing disruptions.
Posted Feb 10, 2020 - 10:49 CET
Update
We are continuing to investigate this issue.
Posted Feb 10, 2020 - 10:40 CET
Investigating
Customers are currently reporting problems using environments in our UK1 hosting location. As a result, UK TOPdesk environments may be slow or unavailable.

We are aware of the problem and investigating possible solutions.

Our apologies for the inconvenience. We aim to update this status page at least every 30 minutes until the issue has been resolved.

If you are affected by this issue, please visit https://my.topdesk.com/tas/public/ssp/ to indicate you are affected.
Please refer to incident 20 02 2573.
Posted Feb 10, 2020 - 10:37 CET
This incident affected: UK1 SaaS hosting location.