TOPdesk SaaS certification renewed
Incident Report for TOPdesk SaaS Status page
Resolved
This incident has been resolved.
Posted May 11, 2021 - 08:32 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 11, 2021 - 08:31 CEST
Investigating
Every year TOPdesk SaaS services are audited by an independent external auditor to verify if our SaaS management systems are adequate for the desired goals, and to check if procedures have been executed correctly. Our certification has been renewed last Friday.

This year’s report has 3 mentionable changes:
• Confidentiality has been added to the already included trust service categories Security, Availability and Privacy
• A new chapter, III.5 Complementary Subservice Organization Controls, describing which third parties are required to build TOPdesk SaaS services upon, how their services relate to criteria TOPdesk is audited on and what we’re doing to ensure that the subservice providers are operating effectively.
• An ISO 27001 mapping. If you are looking or in preference of an ISO 27001 report, you can use the included framework mapping, showing how controls in this ISAE 3000 SOC2 audit report map to ISO 27001


For more information regarding our SaaS hosting and certification, see our SaaS information website (https://page.topdesk.com/saas-information).

Should you wish to receive a copy of the audit report, please contact your account manager.
Posted May 10, 2021 - 16:24 CEST
This incident affected: General notifications.