Extranet unavailability
Incident Report for TOPdesk SaaS Status page
Resolved
The incident has been resolved and extranet is available once more.
Posted Aug 15, 2019 - 11:02 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 15, 2019 - 10:50 CEST
Identified
We are currently experiencing problems with our extranet application. As a result you are unable to log or see the status of your incidents and changes.

Please visit https://page.topdesk.com/contact-support to contact our support department.
Posted Aug 15, 2019 - 10:42 CEST
This incident affected: My TOPdesk.