Disruption in US1 hosting location
Incident Report for TOPdesk SaaS Status page
Resolved
The US1 mail relay is working as expected, and the pending emails are being sent.
Posted Sep 23, 2020 - 01:01 CEST
Identified
We have identified the issue together with our hosting provider and applied a fix. At the moment all queued e-mails on our US1 mail relay are being sent out. Note that this process can take a while.
Posted Sep 23, 2020 - 00:39 CEST
Update
We are continuing to investigate this issue.
Posted Sep 23, 2020 - 00:31 CEST
Investigating
US1 customers who are using our email relay server can notice a delay while sending emails out from TOPdesk. We are aware of the problem and working on a solution. We are in contact with our hosting provider to find a solution.

All emails are in a queue and will be delivered as soon as the issue is resolved.

To inform TOPdesk you are affected by this issue, please visit https://my.topdesk.com/tas/public/ssp/ . Please refer to incident TDR20 09 7173.
Posted Sep 23, 2020 - 00:30 CEST
This incident affected: US1 SaaS hosting location.