RESOLVED: TOPdesk environments are not available
Incident Report for TOPdesk SaaS Status page
Resolved
After a period of monitoring and reports of customers, we have concluded that Microsoft successfully fixed the Exchange Online services availability. Please contact TOPdesk Support if you are still running into any issues with your environment.
Posted Jun 21, 2022 - 15:28 CEST
Update
Some customers are still experiencing issues importing email into TOPdesk from Microsoft Exchange Online mailboxes. 

Microsoft updated their status page: Users may experience delays or access issues in the Exchange Online service via any connection mehod.

Admins have access to the service health status of Microsoft itself:

https://portal.office.com/adminportal/home#/servicehealth
Posted Jun 21, 2022 - 11:05 CEST
Update
TOPdesk is operational again, but we notice that some functionalities that uses integrations with other systems, like mailimport, Single Sign On and Action Sequences, are not working properly yet. 

We are still investigating this issue.
Posted Jun 21, 2022 - 10:32 CEST
Monitoring
A fix has been implemented by our CDN provider. All TOPdesk environments should be operational again. 

We are closely monitoring the status.
Posted Jun 21, 2022 - 09:31 CEST
Update
Some environments seems to be available again. We also noticed that the connection is not stable yet. We are closely monitoring the status.
Posted Jun 21, 2022 - 09:16 CEST
Update
The issue is identified and a fix is being implemented by our CDN provider.
Posted Jun 21, 2022 - 09:02 CEST
Update
Our CDN provider is currently investigating issues with their services and/or network. Users may experience errors or timeouts reaching Cloudflare’s network or services.

For updates check:

https://www.cloudflarestatus.com/incidents/xvs51y9qs9dj
Posted Jun 21, 2022 - 08:51 CEST
Investigating
We are currently experiencing problems on all our hosting locations due to a problem at our Content Delivery Network. As a result your TOPdesk environment may show a '500 internal server error' message.

We are aware of the problem and are working on a solution.

Our apologies for the inconvenience. The current status can be found on our TOPdesk Status Page: https://status.topdesk.com

To inform TOPdesk you are affected by this issue, please visit https://my.topdesk.com/tas/public/ssp/ . Please refer to incident TDR22 06 4723.
Posted Jun 21, 2022 - 08:48 CEST
This incident affected: AU1 SaaS hosting location, BR1 SaaS Hosting location, CA1 SaaS hosting location, EU1 SaaS hosting location, NL3 SaaS hosting location, UK1 SaaS hosting location, and US1 SaaS hosting location.