Disruption in NL3 hosting location
Incident Report for TOPdesk SaaS Status page
Resolved
One of the machines hosting services for TOPdesk became overloaded. Other machines in the network took over as intended, but after a while they were no longer able to take over the load from the unresponsive machine. Once the unresponsive machine was restarted and services were redistributed over all available machines, the performance issues were resolved.

TOPdesk is still investigating why the machine became overloaded, what can be done to prevent and better detect this, and how we can reduce the impact should this issue occur again. We expect to post a more detailed root cause analysis on our Status page in 1 week.
Posted Sep 21, 2020 - 09:55 CEST
Investigating
Several customers in our NL3 hosting location reported performance issues. We're investigating if a common cause can be found for these problems.

To inform TOPdesk you are affected by this issue, please visit https://my.topdesk.com/tas/public/ssp/ . Please refer to incident TDR20 09 6044.
Posted Sep 21, 2020 - 09:33 CEST
This incident affected: NL3 SaaS hosting location.