Slow TOPdesk environments because of high CPU usage on application servers
Incident Report for TOPdesk SaaS Status page
Resolved
This week there were several reports of unavailable environments or slowness. Further investigation shows there is no single root cause. All issues were investigated thoroughly and different issues impacted different environments.

All the issues identified will be followed up (see below). One of the issues (degraded performance when using the Odata feed), is planned to be fixed in the next update of TOPdesk.

We are seeing that the frequency of these issues has decreased. This major will now be closed but we will continue working on the identified issues. Resolved issues will be communicated via the Release Notes page.

Identified issues causing high CPU or memory load for which a fix will be developed
- Extremely Large Form Designer Forms with more than 100+ questions
- High frequency of API calls within a short duration of time
- Certain cases of new Import functionality (e.g. Azure import)
- Unexpected loop in knowledge base search index creation
- Action sequence execution log with more than 50.000 records (which should be capped at 50)
Posted Dec 13, 2019 - 17:47 CET
Update
Investigation unto this issue is still ongoing by the multidisciplinary team.

A clear cause for the high CPU usage has not been verified yet, but are monitoring the situation closely. When the issue occurs, we take immediate action to mitigate its effect on performance.
Posted Dec 12, 2019 - 21:41 CET
Update
We have been investigating the high CPU usage on the application servers today with the highest priority, but no clear cause has been verified yet.

Some causes have been eliminated and a substantial amount of incidents have been closed. Investigation is ongoing.
Posted Dec 11, 2019 - 17:23 CET
Update
We are picking these issues up with the highest priority. A multidisciplinary team is investigating the root cause of the performance problems.

Since the causes are quite complex, we are making progress by identifying different possible causes, as well as their effect on performance.
Posted Dec 11, 2019 - 10:48 CET
Update
We are still investigating the performance problems on our SaaS environments. We suspect that a new feature is causing the CPU spikes.

If you experience performance problems today, please update your incident linked to this major (19 12 3141).
Posted Dec 11, 2019 - 08:52 CET
Update
We've investigated several cases where environments caused a high CPU load, but so far no common cause has been identified.
Posted Dec 10, 2019 - 16:30 CET
Investigating
Several customers report slowness while working in TOPdesk. We notice the CPU usage of TOPdesk environments is much higher than usual.

If you experience problems while working in TOPdesk, please contact TOPdesk Support after submitting an incident. Our Support team can store additional logfiles to investigate the root cause of this problem, and restart your TOPdesk environment to mitigate the impact.

Please visit https://my.topdesk.com/tas/public/ssp/ to indicate you are affected. Please refer to incident 19 12 3141.
Posted Dec 10, 2019 - 16:27 CET
This incident affected: NL3 SaaS hosting location.