The access to my.topdesk has been restored. The issues caused by the maintenance on the 6th-7th of June have been resolved. The cause will be evaluated to prevent similar issues in the future.
We apologize again for any inconvenience and thank you for your patience.
Posted Jun 09, 2026 - 15:23 CEST
Investigating
We are currently experiencing disruptions with access to my.topdesk.com
Over the weekend (June 6th to 7th), we scheduled maintenance to update our AD FS and MiM systems. During this process, we encountered several issues that we have not yet resolved. We are actively working to restore access to My TOPdesk as swiftly as possible.
Currently, login to My TOPdesk is temporarily unavailable
If you would like to register an incident with support, please send an email to support@topdesk.com
Our apologies for the inconvenience. At the time of writing this we are not able to give you an estimate on when My TOPdesk will be available. The next update will be provided as events warrant until the issue has been resolved.
E-mail updates will be sent right away when the issue has been resolved. You can subscribe on the status page (https://status.topdesk.com) for additional updates.
Posted Jun 08, 2026 - 10:11 CEST
This incident affected: Functionality malfunction.